Reply

[How To] Tune SQ for max performance and reduce memory usage by 4 to 5 times

99 replies

_Cujo

Customer, bbp_participant, community, 104 replies.

Visit profile

5 years ago #136640

…snip…

 

I have also implemented your recommended “replace the JVM from Oracle to the one from Zulu”. Though this is working fine, I have found that SQ launch and initial operation with Zulu is much slower than previously with Oracle. Though, within 10-20min SQ performance is back to being similar to Oracle. This happens upon ‘each’ launch of SQ, not just the 1st launch after PC boot-up. Is this to be expected with Zulu JVM?

 

…snip…

 

Hi AC, I was getting what you report – slower, sluggish SQ starting, and not noticeably faster. I even ran side by side instances of Zulu vs non-Zulu, and found the Zulu SQ instance tangibly slower (~100 genetic strategies in last generation every 3-4 hours slower, which really mounts up over a few days).

 

I back tracked, and worked through the Zulu installation guide again. This specifically seemed to make the difference for me. Maybe it’s just perception, as I haven’t rerun a side by side comparison (yet), but it seems faster now. Also, it’s no longer sluggish when SQ starts.

 

You can verify Zulu is running by following this (do it from CMD in the run window, so you can read it). I also found that out as working through the Zulu instructions.

 

Also to say thanks Geektrader.

0

AC1962

Customer, bbp_participant, community, sq-ultimate, 92 replies.

Visit profile

5 years ago #136827

Hi _Cujo

 

Thanks for your suggestion, which I have now tried out. However this change to the environment variable setup makes no difference to the performance of SQ with Zulu-9 JVM on my PC. SQ start-up is equally as slow for me, whether I select ‘Zulu-9’ or ‘Oracle’ as the default Java installation path.

 

Thanks again

AC1962

0

_Cujo

Customer, bbp_participant, community, 104 replies.

Visit profile

5 years ago #136922

Hi _Cujo

 

Thanks for your suggestion, which I have now tried out. However this change to the environment variable setup makes no difference to the performance of SQ with Zulu-9 JVM on my PC. SQ start-up is equally as slow for me, whether I select ‘Zulu-9’ or ‘Oracle’ as the default Java installation path.

 

Thanks again

AC1962

 

Sorry it didn’t work out for you. Mine works great now, must be something else with yours (clearly). Good luck identifying it!

0

mikeyc

Customer, bbp_participant, community, 878 replies.

Visit profile

5 years ago #137441

Hi,

 

I’m only just looking at using the Zulu JVM, thank’s for you effort Geektrader.

 

Question – Do I download the Client or Server files for Windows?

 

EDIT – Okay stoopid question. Please ignore.

 

Cheers,

 

Mike

0

pknoell

Customer, bbp_participant, community, 16 replies.

Visit profile

5 years ago #138485

 

Hello to all,
 
I have a xeon processor E5 1660 v3 running on windows 7,
 
the processor utilization never goes over 20%.
 
I set SQ to use 16 threads, and also using this tune does not go better.
 
Do you have any advice?

 

 

Hi Veone,

 

I had the same Problem with a dual Xeon 2630v4 with Windows Server 2012.

I run 7 Instances with 16 therads each and got only about 50% of cpu usage and a cpu clock-speed of only 1.2 GHz (2,4 is max).

 

I found out, that I had to disable all of the energy saving features.

 

In Windows 2012 Server you can do using the command-line:

 

cmd.exe

Powercfg -setacvalueindex scheme_min sub_processor PERFBOOSTMODE 1
Powercfg -setacvalueindex scheme_min sub_processor PROCTHROTTLEMIN 100
Powercfg -setacvalueindex scheme_min sub_processor CPMINCORES 100
Powercfg -setactive scheme_min

After this commands I have nearly 100% cpu-usage and a full cpu-clock.

 

PK

0

Stradegy7777

Customer, bbp_participant, community, 29 replies.

Visit profile

5 years ago #139186

Hello 

 

Is there more opportunities to speed up SQ

0

GACKT

Customer, bbp_participant, community, 41 replies.

Visit profile

5 years ago #139973

In some cases when I run WFM the memory spikes at the end around 15000 runs and the process freezes and stops.

 

I tried allocating as much RAM as I can (6 GB). It’s not much but WFM has worked without problem with most strategies.

(I bought 8 GB extra RAM but the screw heads for opening my laptop are stripped so can’t install it XD  Will continue to try methods from wikihow :P)
 

Any tips software-wise?

0

mabi

Customer, bbp_participant, community, 262 replies.

Visit profile

5 years ago #140162

@GACKT

 

Just could run different settings for WFM individually to lower the amount of Iterations done. Or get a small drill bit and drill the stripped screws away..

 

Or lower the amount of cores in use for WFM could do it as well.

0

osfx

Customer, bbp_participant, community, 1 replies.

Visit profile

4 years ago #140825

Hi,

 

I am using SQ along with the Zulu Java Version 9.0.0.2. and the extended command line.

The strategy building process itself is working fast and smooth, but starting SQ and navigating within the program became very slow and sticky.

 

I am using it both on my VPS Windows Server 2008R2 (8GB RAM, Intel Xeon E5-2620) and my Windows 10 pro Notebook (8GB RAM, Intel i7-6500U), and both systems show this behaviour.

 

Does anyone have an idea, how to fix it ?

 

Thanks, Oliver

0

matka

Customer, bbp_participant, community, 189 replies.

Visit profile

4 years ago #140826

Hello Oliver,

Thanks for sharing your experience. I have same issue with W7/Intel. No idea how to fix this. It is not significantly slow for me, however visibly slower than without Zulu.

Regards

m

0

ebiesczad

Subscriber, bbp_participant, community, 1 replies.

Visit profile

4 years ago #140913

My SQ used to generate strategies in 0.400s more or less but now all of the sudden this time is about 4 seconds per strategy, which is really slow.

 

I already used the command line suggested and tuned the memory to 16gb which is how much I have availabe and the problem continues.

 

I don’t know why the performance dropped so much. By the way I’m using the fastest methods possible to generate the strategies… the program has all this RAM available and it’s not using any.

 

Any help?

0

fenky0304

Customer, bbp_participant, community, 1 replies.

Visit profile

4 years ago #142069

dear geektrader:

 wow it’s amazing…and thanks for your share!!!! 🙂

0

[email protected]

Customer, bbp_participant, community, 80 replies.

Visit profile

4 years ago #195951

Hello geektrader,
Thank you for this great method to speed it up.
BTW, Can I use this same way in the SQ4 ?

Malim

Malim

0

[email protected]

Customer, bbp_participant, community, 80 replies.

Visit profile

4 years ago #197337

I have tested it and found that this is not work in SQ4 any longer. I’ll wait and see how SQ4 will be optimized.

Malim

0

ivan

Subscriber, bbp_participant, community, 237 replies.

Visit profile

3 years ago #233887

I also hope that SQ4 will have these 2 problems resolved, the correct amount of memory the program sees and a user can set and the garbage problem

the biggest impact is in the Monte Carlo robustness tests when it freezes at any level beyond 100 strategies

so far its like a plane which as long as it flies subsonic its ok but if you want supersonic, it hits a wall

one option is to test the strategies in smaller clusters

Timisoara, Romania
3900X 3.8 Ghz 12 cores, 64GB RAM DDR4 3000Mhz, Samsung 970 EVO Plus M.2 NVMe

0

Viewing 15 posts - 76 through 90 (of 100 total)

1 2 3 5 6 7