Not logged in

Forums

Viewing 15 posts - 1 through 15 (of 15 total)

Forums>EA Wizard>Application Support>Problem with custom indicator Murray Math Lines

  • #114682 |
    Customer
    10 Posts

    Hello,

     

    I am currently struggling to make eawizzard react on one of my newly added custom indicators.

     

    I have al my indicator buffers correctly linked to their output’s and it draws everything correctly if I visually backtest within the strategy tester. Unluckily it doesn’t open any trades and neither shows any price data in it’s buffers as shown in the screenshot made of the chart data window.

     

     

    KInd regards,

    Wouter Vermeersch

     

     

    Attachments in this forum are visible only for registered users.
    Attachments in this forum are visible only for registered users.
    Attachments in this forum are visible only for registered users.
    Attachments in this forum are visible only for registered users.
    Attachments in this forum are visible only for registered users.
    #135284
    Moderator
    2349 Posts

    What testing precision do you use in MetaTrader? Have you used ‘every tick’?

    #135285
    Customer
    10 Posts

    Yes i did use every tick, could this be the problem ..?

    Verzonden vanaf mijn iPhone met Tapatalk

    #135286
    Moderator
    2349 Posts

    Send me the indicator if you can so I can do testing. What could also help is to set bars ago to 0 instead of 1.

    #135287
    Customer
    10 Posts

    If you mean the shift, then I’ve also allready tried that… Once I’m at home I’ll send it to you.

    Verzonden vanaf mijn iPhone met Tapatalk

    #135290
    Customer
    10 Posts

    Here is the indicator code

    Attachments in this forum are visible only for registered users.
    #135325
    Moderator
    2349 Posts

    The problem seems to be in comparison between Bid and indicator value. Bid is 5 decimals while indicator can be 8 decimals or so. This way they will never match. Use ROUND function in Wizard to round the indicator value to 5 decimals. Then it should match the bid. See screenshot attached.

    Attachments in this forum are visible only for registered users.
    #135330
    Customer
    10 Posts

    I’ll go try that right away, the round function won’t be difficult to find I presume ?

    Verzonden vanaf mijn iPhone met Tapatalk

    #135332
    Customer
    10 Posts

    This actually made it work, 

     

    Is there also a function which recognizes the difference between rounding to 3 or 5 decimals in case of yen pairs? or should I just make a separate EA for the yen pairs with fixed rounding to 3 decimals?

     

     

    I am very grateful for you’re excellent support thomas, 

     

    In return I would like to stay around a little longer and share some of my knowledge if needed.

    #135338
    Moderator
    2349 Posts

    You can set a varible roundDecimals (int type) and use it in Wizard rounding function. This way you can change rounding as your EA input parameter. When you load your EA up on chart you will adjust EA parameter for selected currency pair

    #135339
    Customer
    10 Posts

    Yes that’s also a possibility, kind of hoped on the existence of an automatic function.

    Verzonden vanaf mijn iPhone met Tapatalk

    #140542
    Participant
    11 Posts

    I’m also having problems importing data for custom indicator:

    f18f4bf63e594ee76c8a2802860d67ad.png

     

    This happens during automatic import procedure.

    Any idea how can I fix this?

    #140598
    Moderator
    2349 Posts

    Hello,

     

    if you have any issues using the automatic import in SQ I suggest to switch to manual method which works well

    #140656
    Participant
    11 Posts

    There’s no information on how to use manual import method in SQ help. Some directions?

    #140662
    Moderator
    2349 Posts

    Hello,

     

    look at the PDF guide page 99 https://strategyquant.com/licenses/d?code=squg

     

    Let me know if any problems with importing

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.