Not logged in

Forums

Viewing 4 posts - 1 through 4 (of 4 total)

Forums>Tick Data Downloader>General Discussion>Tick Data Downloader Max CPU

  • #117768 |
    Customer
    4 Posts

    Morning,

     

    I sent this last night, and it has not been posted. Wanted to resend it. I’m considering the other products, but my concern is with the Tick Data Downloader. The Application was Max’ing out a 4-core system. I thought maybe I had selected to much data to download at the same time, so I started downloading one at a time; after it had finished downloading one of the pair, the application was still using 98% of my CPU.  Any ideas why the application would utilize that much CPU, when it had finished downloading and should have been idle?

     

    Thanks, James

    #144754
    Moderator
    2349 Posts

    Hello,

     

    we would need to investigate this deeper. You could provide recent log files from the TD /log folder

    #197444
    Customer
    4 Posts

    Hello,
    So I just recently purchased SQ and started trying again to download data using TickDownloader. It still used 100% of my cpu. I then tried to do just one currency pair. Worked fine for a while, but when I came back to my computer 100% cpu just trying to download one currency pair. I have an 8 core processor which runs about 3% utilization, when nothing is running. The only process I had running was the TickDownloader. The previous suggestion in the thread was to check the log file. There is nothing really interesting in it. I copied it below. Where there is ####, I took my username out.

    12:29:28.143 [main] INFO TDDMainApp – ———————————————————————————————
    12:29:28.146 [main] INFO TDDMainApp – Starting application
    12:29:28.169 [main] INFO TDDMainApp – Properties: {java.runtime.name=Java(TM) SE Runtime Environment, sun.boot.library.path=D:\TickDownloader\j64\bin, java.vm.version=25.31-b07, java.vm.vendor=Oracle Corporation, java.vendor.url=http://java.oracle.com/, path.separator=;, java.vm.name=Java HotSpot(TM) 64-Bit Server VM, file.encoding.pkg=sun.io, user.country=US, user.script=, sun.os.patch.level=, java.vm.specification.name=Java Virtual Machine Specification, user.dir=D:\TickDownloader, java.runtime.version=1.8.0_31-b13, java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment, java.endorsed.dirs=D:\TickDownloader\j64\lib\endorsed, os.arch=amd64, java.io.tmpdir=C:\Users\#######\AppData\Local\Temp\, line.separator=
    , java.vm.specification.vendor=Oracle Corporation, user.variant=, os.name=Windows 8, application.home=D:\TickDownloader\, sun.jnu.encoding=Cp1252, j2e.app.path=D:\TickDownloader\TickDownloader.exe, java.library.path=D:\TickDownloader;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\AMD\ATI.ACE\Core-Static;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Skype\Phone\;C:\Users\jkwad_000\AppData\Local\Microsoft\WindowsApps;;., sun.awt.enableExtraMouseButtons=true, java.specification.name=Java Platform API Specification, java.class.version=52.0, sun.management.compiler=HotSpot 64-Bit Tiered Compilers, os.version=6.2, user.home=C:\Users\#####_000, user.timezone=America/Chicago, java.awt.printerjob=sun.awt.windows.WPrinterJob, file.encoding=Cp1252, java.specification.version=1.8, java.class.path=D:\TickDownloader\TickDownloader.exe;, user.name=jkwade, java.vm.specification.version=1.8, java.home=D:\TickDownloader\j64, sun.arch.data.model=64, user.language=en, java.specification.vendor=Oracle Corporation, awt.toolkit=sun.awt.windows.WToolkit, java.vm.info=mixed mode, java.version=1.8.0_31, java.ext.dirs=D:\TickDownloader\j64\lib\ext;C:\WINDOWS\Sun\Java\lib\ext, sun.boot.class.path=D:\TickDownloader\j64\lib\resources.jar;D:\TickDownloader\j64\lib\rt.jar;D:\TickDownloader\j64\lib\sunrsasign.jar;D:\TickDownloader\j64\lib\jsse.jar;D:\TickDownloader\j64\lib\jce.jar;D:\TickDownloader\j64\lib\charsets.jar;D:\TickDownloader\j64\lib\jfr.jar;D:\TickDownloader\j64\classes, java.vendor=Oracle Corporation, file.separator=\, j2e.class.path=D:\TickDownloader\TickDownloader.exe;, java.vendor.url.bug=http://bugreport.sun.com/bugreport/, sun.io.unicode.encoding=UnicodeLittle, sun.cpu.endian=little, sun.desktop=windows, sun.cpu.isalist=amd64}
    12:29:28.210 [main] INFO TDDMainApp – Computer name: ########, User name: ######
    12:29:30.031 [main] INFO SQPluginManager – Loading plugin ‘DukascopyTab’
    12:29:30.031 [main] INFO Program – Program ‘DukascopyTab’ was registered.
    12:29:30.031 [main] INFO SQPluginManager – Loading plugin ‘AdAA’
    12:29:30.047 [main] INFO SQPluginManager – Loading plugin ‘AdEAA’
    12:29:30.047 [main] INFO SQPluginManager – Loading plugin ‘AdEAW’
    12:29:30.062 [main] INFO SQPluginManager – Loading plugin ‘AdSQ’
    12:29:30.315 [main] INFO SQPluginManager – Loading plugin ‘TDDOptionsPlugin’
    12:29:30.315 [main] INFO SQPluginManager – Loading plugin ‘PluginManager’
    12:29:30.315 [main] INFO Program – Program ‘PluginManager’ was registered.
    12:29:30.315 [main] INFO SQPluginManager – Loading plugin ‘TDDAdPlugin’
    12:29:31.317 [main] INFO SQLicenser – L: 012345
    12:29:31.317 [main] INFO TDDMainApp – Checking for updates.
    12:29:31.833 [main] INFO SQUpdater – Checking for updates. Mode[mode_release]
    12:29:32.281 [main] INFO TDDMainApp – No updates were found.
    12:29:34.353 [AWT-EventQueue-0] INFO DIRloader – Loading available data. Directory: .\tickdata
    12:30:26.056 [AWT-EventQueue-0] INFO DukascopyPanel – Start Downloading data – 16.09.2017 17:30:26
    17:58:03.993 [AWT-EventQueue-0] INFO MainEngine – Stopping…
    17:58:43.016 [AWT-EventQueue-0] INFO DukascopyPanel – Done in 5h 28m

    #197445
    Customer
    4 Posts

    I notice that folks put in a lot of threads about the download being slow. When CPU is at 100%, the single download crawls. It may be that some of them are experiencing the same problem, but not checking there cpu utilization.

    Let me know if you need additional information from me on this problem.

    • This reply was modified 10 months ago by  JKip.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.