Not logged in
Viewing 3 posts - 1 through 3 (of 3 total)

Forums>StrategyQuant>General Discussion>Genetic Algo not producing offspring via two parents…. Please prove me wrong

  • #267083 |
    Customer
    68 Posts

    Is it possible that the reason the genetic builder needed so many Band-Aids is that the breeding function of the algo never actually worked?

    I’ve done this experiment now several times with various settings (In some cases I had to restart SQX in order to get mutation setting to “take” when I set it to 0)

    Set mutation to zero, disable fresh blood options, set crossover to (presumably) any non zero. After gen #1 finishes, no new strategies are tested beyond gen 1 and all the generations instantly complete after that without any testing or log entries. We would expect some brand new strategies to be produced as children of two parents via breeding which would need to be tested.

    no breeding

    Set mutation to 1% but keep the fresh blood turned off and set crossover to 50%. A handful of new mutations (as expected – In SQ the mutation rate is applied to each block/variable) are produced and tested. The island “last generation” tab has a chance to refresh each gen this time so we can see what’s going on now. By gen#3 many EXACT copies of the (presumably) best strategies from the previous gens or now visible.

    It looks like the crossover function is just making extra exact copies of the best strategies and bringing them to the next generation. No wonder pre-mature convergence was an issue! How useful are the migrations between islands if there is no breeding happening?

    Further more with mutation again set to zero, you can see all the fitness lines of “in sample” just converges on the top strategy again and again. If strategies were breeding, we would expect to see an even better top strategy at least sometimes but that’s not the case ever…. Here are some examples from yesterday when I turned off all OOS segments including validation.

    Attached here are some settings to experiment with, the mutation is set to 0%. Try setting it to 1% if you want to see what’s going on in the “last generation” tab, otherwise it never has a chance to refresh.

    Bug report here:
    https://roadmap.strategyquant.com/tasks/sq4_7128

    Attachments:
    You must be logged in to view attached files.
    #267178
    tomas262
    Administrator
    1826 Posts

    Hello,

    thanks for your feedback. Developers will check this and the task mentioned. This needs to be verified. If the issue is identified into can be fixed into next update likely

    #267184
    Customer
    68 Posts

    Fixed!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.