Not logged in
Viewing 5 posts - 1 through 5 (of 5 total)

Forums>StrategyQuant>Application Support>Money Management bug – big problem

  • #267831 |
    Customer
    119 Posts

    I posted this in tasks – but no response.  Need applications support please.

     

    Both on V129 and V130 (beta), while doing BT (in SQX) and optimization using MM function, SQX is not applying the correct logic or math.  Hence, I will never be able to get the correct stats until I move it to MT4 for BT.  There are huge spikes in the lot size in SQX.  When will this be fixed?  Thanks.

    Attachments:
    You must be logged in to view attached files.
    #267839
    Customer
    791 Posts

    you can investigate it in SQX – turn on “store chart data” in trading options, retest – so you can see the trades doing this in the SQX itself and you can maybe find what this causing this – isnt there any gaps in data, etc. etc.

    hard to say without the SQX file more

    You want to be a profitable algotrader? We started using StrateQuant software in early 2016. For now we have a very big knowhow for building EAs for every possible types of markets. We share this knowhow, apps, tools and also all final strategies with real traders. If you want to join us, fill in the FORM. 1500+ final SQX strategies for members running on demo accounts to verify the edge DEMO ACCS. We provide also strategies for indices - DAX, DOW JONES, NASDAQ, SP, UK, because we have realtick data from our brokers.

    #267853
    Customer
    119 Posts

    I just posted this in Tasks too.  Here is just one example.  What it looks like is that the MM function is working until several times it will revert to “if no MM, then” and there is a 1 lot in that space.  This is happening on retester and optimization.  Every strategy is experiencing this.

    Attachments:
    You must be logged in to view attached files.
    #267854
    Customer
    119 Posts

    UDPATE – Tomas from support just addressed this in the Tasks area.  Apparently there is no bug.  The MM function is working as it should although you need to change the default 1 in the ifnomm space to .01 or 0.  The algorithm is seeing the account equity is too low for a % of balance trade and reverts to this input.  So I just wanted to post this in case anyone is seeing this problem.

    #267901
    Customer
    109 Posts

    If account balance is too low, it reverts to this value.

    This is actually very helpful… I didn’t realize it was doing this.  This is not expected behavior.

    Thanks for sharing.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.