Dokumentation & Benutzerhandbücher

Lernen Sie die Grundlagen, oder verfeinern Sie Ihre Fähigkeiten mit Tutorials, die Sie inspirieren werden.

Zuletzt aktualisiert am 30. 1. 2016 von Mark Fric

Spezielle Exporteure für den Handelsverlauf für MetaTrader und Tradestation

In Version 4.10 wurden spezielle Handelsexporteure für MetaTrader und Tradestation hinzugefügt.

Sie haben zwei Vorteile:

  • sie ermöglichen den "automatischen" Export von Geschäften in eine vordefinierte CSV-Datei, ohne dass die Berichtsdatei manuell gespeichert werden muss
  • MAE (max. offener Verlust) und MFE (max. offener Gewinn) werden für jeden Handel aufgezeichnet. Dies ist nur bei Berichten möglich, die auf diese Weise geladen werden, und es wird MAE/MFE im Aktienchart angezeigt.

Wie installiert man Exporteure für den Zollhandel:

Für Tradestation

  1. Importieren Sie die Datei SQEXPORTTRADES.ELD in Tradestation über Datei -> Import/Export EasyLanguage -> Import EasyLanguage File (ELD). Die Datei befindet sich im Ordner /loaders in der QA-Installation.
  2. dann fügen Sie den Befehl: Value90 = SQExportTrades("C:Your_File_Name.csv", 10) ganz am Ende Ihrer Strategie.

Die Handelsergebnisse werden dann in die Datei C:Your_File_Name.csv exportiert.

Diese Funktion hat zwei Parameter:
- Dateiname mit vollständigem Pfad
- ATR-Periode - ATR-Periode, die aufgezeichnet wird, wenn der Handel eröffnet wird. Sie kann später verwendet werden, um z.B. die Volatilität zu berechnen, als der Handel eröffnet wurde. Sie können 1 einstellen, wenn Sie sie nicht verwenden möchten.

Für MetaTrader

  1. Kopieren Sie die Datei SQLogTrades.mqh in Ihren MQL4Include-Ordner - Sie finden den Ordner in MetaTrader4 unter Datei -> Datenordner öffnen. Die Datei befindet sich im Ordner /loaders in der QA-Installation.
  2. In Ihrem EA müssen Sie vier Dinge tun:
    1. Binden Sie die Datei SQLogTrader.mqh mit #include<SQLogTrades.mqh in Ihren EA ein.
    2. den Befehl sqInitLog("Ihr_Dateiname.csv", 0, 10); zur Funktion OnInit() / init() hinzufügen.
      Wenn diese Funktion in Ihrem EA nicht vorhanden ist, müssen Sie sie erstellen.
    3. den Befehl sqCloseLog(); zur Funktion onDeinit() / deinit() hinzufügen.
      Wenn diese Funktion in Ihrem EA nicht vorhanden ist, müssen Sie sie erstellen.
    4. den Befehl sqLogTrades(); ganz am Anfang der Funktion OnTick() / start() hinzufügen.

Die Handelsergebnisse werden dann in eine Datei exportiert /tester/files/Ihre_Datei_Name.csv.
Sie können den Tester-Ordner mit MetaTrader4 unter File -> Open Data Folder aufrufen

Diese Funktion hat drei Parameter:
- Dateiname mit vollständigem Pfad
- magische Zahl - wenn nicht 0, werden nur Geschäfte mit der angegebenen magischen Zahl erfasst
- ATR-Periode - ATR-Periode, die aufgezeichnet wird, wenn der Handel eröffnet wird. Sie kann später verwendet werden, um zum Beispiel zu berechnen
Volatilität, wenn der Handel eröffnet wurde. Sie können 1 einstellen, wenn Sie sie nicht verwenden möchten.

Beispiel - alter MQL-Code-Stil:

...
#include
...

int init() {
sqInitLog("My_EA_Results.csv", 0, 10);
...
return(INIT_SUCCEEDED);
}

void deinit(const int reason) {
sqCloseLog();
...
}

void start() {
sqLogTrades();

...
}

Beispiel - neuer MQL-Codestil

...
#include
...

int OnInit() {
sqInitLog("My_EA_Results.csv", 0, 10);
...
return(INIT_SUCCEEDED);
}

void OnDeinit(const int reason) {
sqCloseLog();
...
}

void OnTick() {
sqLogTrades();

...
}

War dieser Artikel hilfreich? Der Artikel war nützlich Der Artikel war nicht nützlich

0 Kommentare
Älteste
Neueste Meistbewertet