Not logged in
Viewing 2 posts - 1 through 2 (of 2 total)

Forums>AlgoWizard / EA Wizard>Application Support>Getting money management to work

  • #113387 |
    Participant
    3 Posts

    Hi All,

     

    I am slowly going mad here as I just cannot get the money management tool within the Wizard to work. Everytime a trade is placed it will always place the maximum lot size of the trade and doesn’t seem to calculate the stop losses that I have in place on the trades.

     

    I have tried using various variables including using the global stop and take profit setting (with the quantity of the trade itself having the “Use predefined Money Management” selected) I have also tried with the stop loss criteria of the trade input manually (as opposed to using the predefined global settings)

     

    I have tried every alternative way of inputting them all i can think of and yet it always just uses the maximum lot (5) amount.

     

    The stop loss I am trying to place is using the ATR function.

     

    Any ideas on what I may be doing wrong?

     

    Thanks

     

    DT

     

     

     

     

     

    #129264
    Mark Fric
    Administrator
    1182 Posts

    please post your strategy here, I cannot find out what could be wrong. 

     

    If EA uses always maximum lots it means the MM computes trade size always as some very big value, and it is trimmed down to maximum allowed lots.

    Mark
    StrategyQuant architect

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.