Not logged in
Viewing 10 posts - 1 through 10 (of 10 total)

Forums>EA Wizard>Make my EA>EA created won't open any trades

  • #250793|
    Participant
    10 Posts

    I have coded an idea as below, but it won’t open any trades.

    Would appreciate any help.

    ====================================================================
    Pseudo Source Code of BBands Sell Side Re-Creation Attempt 1

     

    Generated by StrategyQuant EA Wizard version 2.0.1
    Generated at Wed Dec 04 10:29:00 EST 2019
    ====================================================================

    //——————————————————————–
    // Variables
    MaxSlippage = 3;
    VerboseMode = 1;

     

    //——————————————————————–
    // Go short

    IF (IsBarOpen is True) && (((Close[2] >= BollingerBand_Upper( 20 , 2 , 0 , Close )[2])
    And (Close[1] <= BollingerBand_Upper( 20 , 2 , 0 , Close )[1])))
    THEN
    Sell (MoneyManagement computed) lots at Market
    Magic Number = 5;

    END IF;

    Attachments:
    You must be logged in to view attached files.
    #250797
    Customer
    16 Posts

    You need to set golbal SL/TP

    #254668
    Participant
    10 Posts

    I’ve added the global SL and TP.

    Still won’t open any trades.

    If anyone can help, would be much appreciated.

    The code is as below:

    ====================================================================
    Pseudo Source Code of BBands Sell Side Re-Creation Attempt 4

     

    Generated by StrategyQuant EA Wizard version 2.0.1
    Generated at Thu Dec 05 14:11:00 EST 2019
    ====================================================================

    //——————————————————————–
    // Variables
    MaxSlippage = 3;
    VerboseMode = 1;

     

    //——————————————————————–
    // Go short

    IF (((Close[2] >= BollingerBand_Upper( 20 , 2 , 0 , Close )[2])
    And (Close[1] <= BollingerBand_Upper( 20 , 2 , 0 , Close )[1])))
    THEN
    Sell 0.1 lots at Market
    Magic Number = 5;
    Stop Loss = Global pips;
    Profit Target = Global pips;

    END IF;

    Attachments:
    You must be logged in to view attached files.
    #254669
    Customer
    16 Posts

    Still won’t open any trades = No signal!!!
    You might run back test on mt4 to check.

    #254670
    Participant
    10 Posts

    Hi Truong,

    I have run a backtest on MT4 using visual mode, and I can definitely see the signal, but no trades opening.

    I coded the strategy using a different EA builder software but also wanted to try building with EA Wizard to become more familiar.

    Thanks for you help anyway, looking forward to anyone else’s input

     

    #254720
    tomas262
    Administrator
    1116 Posts

    Works like a charm for me. Have you checked the MT journal for possible errors?

    Attachments:
    You must be logged in to view attached files.
    #254726
    Participant
    10 Posts

    I attached the journal file.

    It doesn’t seem to have any errors – or am I missing something?

    Did you make any modifications to the strategy file, tomas262?

     

     

    • This reply was modified 2 days, 16 hours ago by  ggiang.
    • This reply was modified 2 days, 15 hours ago by  ggiang.
    Attachments:
    You must be logged in to view attached files.
    #254735
    tomas262
    Administrator
    1116 Posts

    No modifications whatsoever, just straight export into MT4

    #254736
    Participant
    10 Posts

    Ok.
    i wonder why it’s not working for me then.
    what version/build of MT4 are you using?

    could it be that your settings/parameters in EA Wizard are different to mine?

    #254737
    Participant
    10 Posts

    Hi, I figured out the issue.

    I was copying the file from a different save location to the experts folder and not directly saving the file into the experts folder.

    Glad I did some re-reading of the user guide. Thanks for the replies.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.