Not logged in
Viewing 4 posts - 1 through 4 (of 4 total)

Forums>StrategyQuant>General Discussion>Improver and Stop Loss

  • #270597 |
    jpcoder
    Customer
    27 Posts

    I was trying to follow the workflow set out in this blog post.

    https://strategyquant.com/blog/edge-ratio-in-strategyquant-x/

    When I use the “Improve existing strategies” function, even though I set the building blocks to require a stop loss like the blog post said, none of the improved strategies include a stop loss.  What am I doing wrong?

    #270607
    jpcoder
    Customer
    27 Posts

    Ok, I think I found the problem.  The article shows to set the Improver’s parts to improve “Exit Rules” to “Replace”.  But that doesn’t seem to actually work.  My guess is because there was no exit rule in the first place (always in the market) it doesn’t know what to replace.  If you set it to “Add” or “Add or Replace” it seems to work.

    SQX support folks, I would consider this a bug.

    #270609
    tomas262
    Administrator
    1823 Posts

    The option “Add or Replace” needs to be used in this case. The logic works the way you cannot replace what does not exist in the first place

    #270611
    jpcoder
    Customer
    27 Posts

    Ok, but I would call that a bug, because replacing nothing with something still makes sense.  I would also suggest updating that blog post.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.