Not logged in
Viewing 6 posts - 1 through 6 (of 6 total)

Forums>AlgoWizard / EA Wizard>Application Support>Order Price too Close to Market Price

  • #113618 |
    Participant
    14 Posts

    Hi,

     

    I have built an EA however on some occasions i am given a error that my pending order is too close to market price. Is their a work around so that in the event that this happens the EA places a order at market price with the same SL and TP?

     

    thank you.

    #129892
    Customer
    432 Posts

    There are min stop loss, min take profit and min distance to market settings, just use them and you are fine:) Also, choose a good broker with 0 stop level. Any other broker with a higher stop level is a market maker and generally not good for your trading;)

    #129913
    Participant
    14 Posts

    Hi,

     

    Thank you for your response however I cannot find the min distance to market settings?

    I guess I can write something stating that the price needs to be greater or less than 1 pip from current price for the pending order and create another rule for buying at market price.

     

    I’m using tallinex, its states zero distance in mT4 however this is in back testing… maybe its a issue with back testing? Im back testing offline with the spread set at 1 pip.

    #129915
    Customer
    432 Posts

    Tallinex is a good broker and has 0 pips stop level everywhere. I am sorry though, I posted in the wrong part of the Forum and did actually think you refer to StrategyQuant. My fault, sorry. For EA Wizard I don´t really know how it´s done.

    #129922
    Customer
    168 Posts

     

     

    Thank you for your response however I cannot find the min distance to market settings?
     

     

    Just click “New Trade” and change type of transation from MARKET EXECUTION to STOP or LIMIT order. At lower part of window You will see required minimum distance for stoploss/takeprofit . TP and SL are exual to minimal distance price form market. 

    btn_viewmy_160x33.png

    #129925
    Participant
    14 Posts

    Thank you for your posts. I’ve managed a work around.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.