Reply

Error opening order:131: invald trade volume with 0.1 lots

2 replies

RBruinsma

Customer, bbp_participant, community, 17 replies.

Visit profile

5 years ago #114468

I try to run an EA created with SQ on a live account (XM forex account) but I keep getting the error:

Error opening order:131: invald trade volume

 

With the test EA run in MT4 I didn’t recieve any errors with exact same EA setting. I’m using 0.1 lot sizes.

 

Any idea what goes wrong?

 

Copy my trades via (strategies created with SQ4):
- MQL5
- Zulutrade
- FXTM
More information or portfolio updates: www.bearsbulltrader.com or follow me on Twitter: BearsBullTrader

0

tomas262

Administrator, sq-ultimate, 674 replies.

Visit profile

5 years ago #134159

it can be broker specific thing but you can try to change ‘LotsDecimals’ to 1 since you don’t use values like 0.05 etc. Have you tried to play live fixed position size?

0

RBruinsma

Customer, bbp_participant, community, 17 replies.

Visit profile

5 years ago #134162

it can be broker specific thing but you can try to change ‘LotsDecimals’ to 1 since you don’t use values like 0.05 etc. Have you tried to play live fixed position size?

I figured it out. After downloading the MT-4 version of XM my problem was fixed. 😉 Also I needed to select microchart to trade 0.1 size lots.

Copy my trades via (strategies created with SQ4):
- MQL5
- Zulutrade
- FXTM
More information or portfolio updates: www.bearsbulltrader.com or follow me on Twitter: BearsBullTrader

0

Viewing 3 posts - 1 through 3 (of 3 total)