Reply

Back testing doesn’t work

3 replies

@rt

Subscriber, bbp_participant, 3 replies.

Visit profile

10 months ago #267138

I have downloaded the data and successfully exported it to MT4 using ExportProperties.mq4 script.
Now, once I try to run a back testing a get a following results:
TestGenerator: file “C:\Users\xxx\AppData\Roaming\MetaQuotes\Terminal\xxxxxxxxxxxxxxxxxxx\tester\history\USDCAD1_0.fxt” is read-only

MT4 discovered a downloaded files and period of the data:
TestGenerator: symbol USDCAD period 1 model 0 from 2003.08.04 to 2020.10.04

The there is some error I don’t understand:
TestGenerator: server “” differs from “Demo” terminal connected to

And then there is a message about some processing:
USDCAD,M1: 1302182 tick events (30210 bars, 266428730 bar states) processed in 0:00:02.625 (total time 0:00:16.250)

If I turn Visual mode ON I see the graph with data ticks running

But there are no results in the Result page

What do I miss?….

In the Journal I see that there was some processing

Attachments:
You must be logged in to view attached files.

0

tomas262

Administrator, sq-ultimate, 708 replies.

Visit profile

10 months ago #267140

Hello,

the TestGenerator: file “C:\Users\xxx\AppData\Roaming\MetaQuotes\Terminal\xxxxxxxxxxxxxxxxxxx\tester\history\USDCAD1_0.fxt” is read-only message is not an error actually. This files was generated by QuantDataManager and the read-only attribute was set. MetaTrader4 basically tries to create its own and overwrite this and that we do not want. I think the backtest should be working good. Have you tested another symbol / market?

0

@rt

Subscriber, bbp_participant, 3 replies.

Visit profile

10 months ago #267152

Is it possible, that the problem is in the set of parameters I choose at the moment I add new instrument?
What is a right place to get pip/Tick size, pip/Tick step, point value?

0

tomas262

Administrator, sq-ultimate, 708 replies.

Visit profile

10 months ago #267174

Hello,

I do not think it is related to parameters set. A simple test of the process being done correctly is to use another MT4 copy and export tick data into that copy. If that works properly then the problem exist only with your original MT4. You can try out IC markets MT4 demo for example https://www.icmarkets.com/global/en/open-trading-account/demo

0

Viewing 4 posts - 1 through 4 (of 4 total)