Reply

Risk Management Stopped Working!

31 replies

DiggerOfTruth

Customer, bbp_participant, community, 65 replies.

Visit profile

6 years ago #113796

HELP! The Risk Managment is on but despite what I do, the EA is placing all orders at 0.01.

 

What is going on?

0

eastpeace

Customer, bbp_participant, community, 295 replies.

Visit profile

6 years ago #130855

chek the parameter of your money management type, is the value is 0 or 1?

0

DiggerOfTruth

Customer, bbp_participant, community, 65 replies.

Visit profile

6 years ago #130868

U must mean True or False.

 

Yes, it is set to True on all instruments. I did not change it at all. Over the weekend all the new orders are only being placed at 0.01 lots, despite the Money Management being True and risk from 2-5% set.

0

DiggerOfTruth

Customer, bbp_participant, community, 65 replies.

Visit profile

6 years ago #130869

I just noticed something:  the only problem came after the weekend on Yadix Live account. Pepperstone’s demo is working fine, new demo and old demo same functionality.

 

WHY it should work differently – with MM not even working on one broker – is beyond me. Any more insight?

0

DiggerOfTruth

Customer, bbp_participant, community, 65 replies.

Visit profile

6 years ago #130872

No, Yadix has not even returned my email to them concerning tens of thousands of percent LOSS on a trade when it should have been stopped out at Break Even, so I haven’t even sent another email regarding this until they respond – or not – to the original one.

0

mikeyc

Customer, bbp_participant, community, 878 replies.

Visit profile

6 years ago #130894

Check the max lots setting in the EA, ensure it it something sensible with money management such as 10 or more.

0

DiggerOfTruth

Customer, bbp_participant, community, 65 replies.

Visit profile

6 years ago #130902

Most r set at 0.5 but that shouldn’t affect it so differently from broker to broker should it?

0

nolube

Customer, bbp_participant, community, 114 replies.

Visit profile

6 years ago #130927

I’m having the same issue with an EA of mine from SQ. When I backtest it, it places all trades as 0.10 lots and it does the same thing on live trading. Any idea what’s wrong? 

 

 

0

mikeyc

Customer, bbp_participant, community, 878 replies.

Visit profile

6 years ago #130933

Does the strategy have a stop loss? If it doesn’t have a stop loss, then MM uses the normal lot size. If you set the lot size to 0.0 then the min broker lot size will be used which is usually 0.1 lots for a standard account. 

 

If the stop loss if very large and the broker account is small, the lot size might be so small to represent 2% of account, that again min broker lot size will be used.

0

nolube

Customer, bbp_participant, community, 114 replies.

Visit profile

6 years ago #130935

Thanks for your reply mikeyc, but yes the strategy has a stop loss. It’s got me stuffed why it’s doing this …

0

mikeyc

Customer, bbp_participant, community, 878 replies.

Visit profile

6 years ago #130980

If it’s any consolation I have a strategy that works fine in SQ, and the EA generated backtests really well.  Tried it on several demo accounts, and it never opens a trade, no errors, no nothing, just won’t open a trade.  I’m completely stumped by it.

0

felipebr

Customer, bbp_participant, community, 19 replies.

Visit profile

6 years ago #131341

I’m getting same problem… can support help please ?

0

tomas262

Administrator, sq-ultimate, 674 replies.

Visit profile

6 years ago #131344

I can check it for you. Please, send your EA (mq4 file) to our support email: support@strategyquant.com

0

DiggerOfTruth

Customer, bbp_participant, community, 65 replies.

Visit profile

5 years ago #132645

Another issue is when SQ is doing its thing – creating strategies – I am finding that even tho MM is set up (2%, 100 lots max) – from the first trade 100 lots is being used on the standard $10,000 start amount.

 

What gives?

0

tomas262

Administrator, sq-ultimate, 674 replies.

Visit profile

5 years ago #132743

What value you used for “Lots if no MM”? When you uncheck “SL is Required” in Strategy Options then SQ will set this value for all trades

0

Viewing 15 posts - 1 through 15 (of 32 total)

1 2 3