Not logged in
Viewing 7 posts - 1 through 7 (of 7 total)

Forums>StrategyQuant>Application Support>BOTS REFUSING TO APPLY TRAILING STOP & B/E TO CLOSE IN PROFIT

  • #234341 |
    Customer
    55 Posts

    Started with Demo account $10,000 – went to $5,000 then to almost $25, 000 in equity but stopped closing in profit with trailing stops! Currently equity is back down to $15,000 and the S/L’s have not moved. (Obviously the bots are catching the moves on the various instruments well, but what good is a bot that won’t close in profit???)

    This same issue happened years ago and clearly there is still a problem(s). WHY?

    #234359
    tomas262
    Administrator
    1821 Posts

    Hello,

    is the EA created with SQ or EAWizard? Can you share more info to support@strategyquant.com? We can check this together

    #234362
    Customer
    55 Posts

    SQ created.

    Not sure what more info you wish. This is a systemic issue clearly.

    #234398
    tomas262
    Administrator
    1821 Posts

    Thanks for providing the details. We will need to test this and look into what could be the cause. I will let you know

    #234412
    Customer
    55 Posts

    Thank you for your reply notch.

    You mean to say that we have to manually code bots made by SQ??? This is a systemic issue that has not been corrected to the present after years of the same issue! (I certainly didn’t pay for a program to have to manually code such things unless that was part of the offer for the program.)

    So you had to manually add this line in each bot that you made?

    #234423
    tomas262
    Administrator
    1821 Posts

    Hello,

    the SQ3 code templates can be modified so a permanent change to the output code can be done. I am checking and testing your codes now

    #234424
    Customer
    55 Posts

    Thank you Tomas:  praying for a righteous resolution for all.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.