Reply

Does SQx remote access works with WAN and LAN of another router?

9 replies

gusyoan

Customer, bbp_participant, community, 20 replies.

Visit profile

1 year ago #255135

hi guys,

by WAN, i want to connect SQ working at my home from my office.

by LAN, my house has 3 routers: 1  fib modem, 2 local routers.  My laptop connect with router A (192.168.0.1) and SQ PC connect with router B (192.168.1.1), i want make a local remote access between A and B.

is it feasible ?

 

thx

 

0

gusyoan

Customer, bbp_participant, community, 20 replies.

Visit profile

1 year ago #255136

because currently i see only http://localhost:8080 there, how can i change the url?

0

ivan

Subscriber, bbp_participant, community, 232 replies.

Visit profile

1 year ago #255150

i think it depends on the software you want to use to connect remotely, if its Windows Desktop Remote or TeamViewer…etc

i use Windows Desktop Remote Connection but on the same router both computers (same physical location). I haven’t tried but i speculate that it could work on different routers because you only need two things: name of the host computer and the password

Timisoara, Romania
3900X 3.8 Ghz 12 cores, 64GB RAM DDR4 3000Mhz, Samsung 970 EVO Plus M.2 NVMe

0

gusyoan

Customer, bbp_participant, community, 20 replies.

Visit profile

1 year ago #255158

hi ivan,

I think windows remote desktop and teamviewer is another issue. The first thing is whether we can change the default url http://localhost:8080

0

tomas262

Administrator, sq-ultimate, 674 replies.

Visit profile

1 year ago #255168

Hello,

to access SQ within your LAN both routers must be within the same network using the same IP range. To access from the outside you need to open the port 8080 and use port forwarding. It should allow you to access SQX (using your public assigned IP)

0

gusyoan

Customer, bbp_participant, community, 20 replies.

Visit profile

1 year ago #255174

hi tomas,

same range means 2 IPs must be in same group of 254 IPs?

does 192.168.1.1 and 192.168.0.1 in same range? both 2 routers connect to same modem

0

SteveChou

Customer, bbp_participant, community, 39 replies.

Visit profile

11 months ago #260353

I think 192.168.1.1 and 192.168.0.1 not the same range.

You need to change them into the same 192.168.1.xxx

0

ivan

Subscriber, bbp_participant, community, 232 replies.

Visit profile

8 months ago #267013

although its not a recent discussion, i would like to add some useful information which might come in handy in the future for other users

to access a computer through windows remote desktop connection from outside the home network, you must set up port forwarding (like tomas262 said) and i will detail with a theoretical example but first some important details:

routers have 2 IP adresses:

one internal, is what you use to talk to your router. It is used to login to your router and in windows powershell or command promt is listed as the default gateway. So the default gateway and the internal IP of the router are one and the same. Its always something like 192.168.xxxxxx

one external IP address, is what the rest of the world uses to find you on the Internet and this is the one used to connect through the windows remote desktop connection. It has a very different form, like 89.137.37.95. This IP can be found out by checking on various specialized sites. You simply open the page of that site and it shows you this IP.

the desktop computer on which SQ is running, computer inside a home network, has a private (internal) IP, used in internal networks only and it changes periodically, in some cases after each restart, as opposed to public (external) IP which is accessible to the outside world and its always the same, The private internal IP has the form of 192.168.0.235.

To set up a port forwarding, you must log on into the router menu and in port forwarding submenu, simply add a new rule in which you put the private internal IP of the desktop computer running SQ, the default port 3389 or other similar port and enable both protocols. Save this new rule and close the menu.

One important detail: because the private, internal IP of the desktop is dynamic, not static, and it changes, this is a problem because once it changes from 192.168.0.235 to 192.168.0.236 or 237, the remote connection wont work anymore and you have to change and update the rule everytime this happens.

Now, the practical example: in the general tab, we have logon settings and we put:

Computer: 89.137.37.95, the external IP address of the router, not any other IP

User name: the user of the desktop running SQ, not the name of the computer. If we have a computer named Gigabyte and the administrator name or user is Christian, we put Christian.

For the final step, you must also write the password to log in, this is the password for Christian account.

I hope this clarifies the whole problem.

Regarding the problem of constantly updating the IP address, the only better more secure way is to use a VPN but this requires a subscription from a provider or, you can set up a VPS at home.

Timisoara, Romania
3900X 3.8 Ghz 12 cores, 64GB RAM DDR4 3000Mhz, Samsung 970 EVO Plus M.2 NVMe

0

ivan

Subscriber, bbp_participant, community, 232 replies.

Visit profile

8 months ago #267014

another solution to the ever changing of the IP, is to use DDNS but only if the router has this feature, some have, others dont. With DDNS you can access your device from the internet via a simple to remember web address instead of a number

Timisoara, Romania
3900X 3.8 Ghz 12 cores, 64GB RAM DDR4 3000Mhz, Samsung 970 EVO Plus M.2 NVMe

0

ivan

Subscriber, bbp_participant, community, 232 replies.

Visit profile

8 months ago #267086

there is another very useful feature related to remote access that users will appreciate, the Wake On Lan. Using a computer remotely and shutting down is useful and simple but starting it remotely is even more useful because once is shut down, there are many situations in which pushing the start button is difficult from another location

Step one: enable the Wake on Lan feature in BIOS

Step two: enable the feature in windows settings in device manager

Step three: set up the port forwarding in the routers menu

Step four (and final): download and install a software on the computer used to operate the remote computer:

https://www.pcwdld.com/free-wake-on-lan-tools

Important notice: the wake on lan feature only works on wired connections, ethernet cable. Does not work on wireless.

Timisoara, Romania
3900X 3.8 Ghz 12 cores, 64GB RAM DDR4 3000Mhz, Samsung 970 EVO Plus M.2 NVMe

0

Viewing 10 posts - 1 through 10 (of 10 total)