Not logged in
Viewing 5 posts - 1 through 5 (of 5 total)

Forums>Quant Analyzer (formerly named EA Analyzer)>General Discussion>How can I load in QA the MT4 report recognized by comment?

  • #203129 |
    17 Posts

    Hi ,  I know that there is a possibility to load live report from MT4 into the QA as Portfolio and recognized by comment (see pciture attachment below). But why is the field not active in QA when I use load report?

    In the comment are the magic numbers in the live report and I will select and sort in the QA portfolio by magic number.



    You must be logged in to view attached files.
    17 Posts

    OK I found an easy solution, but I don’t know, why it is not implemented in QA4:

    1. Convert and save the MT4 html report file in an csv file.

    2. Change the  file GeneralCSVImport in the folder C:\QuantAnalyzer4\settings\plugins\LoaderGeneralCsv

    Format.3.DateFormat=yyyy.MM.dd HH:mm:ss

    3. Now the QA4 can read your csv file including your comment and if you want additonal colums….

    Also the comment field in loading process portfolio is now open (see the attachments).

    Hope this will help also other trader …

    Regards Chris



    You must be logged in to view attached files.
    1826 Posts


    yes, and by additional modifying the CSV config file you also import reports having different data formats. Let me know if any issues

    256 Posts

    Hi Chris. Good Job. Thanks

    2 Posts

    Try to parse file with date&time in column “DATETIME” with plain format “Format.3.DateFormat=yyyy.MM.dd HH:mm:ss” (example: “2017.08.22 09:36:55”) , however i catch the error:

    – error loading using GeneralCsv loader – Incorrect csv file or format unrecognized. Failed to parse order. Reason: Unknown column type! Type: DATETIME
    Line: 2017.08.14 13:48:54,XAUUSD.m,2,buy,In,…

    So it seems that some date&time formats couldn’t be recognized even in case of correct specification of new format in GeneralCSVImport.ini.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.