Not logged in
Viewing 7 posts - 1 through 7 (of 7 total)
  • #268888 |
    Customer
    119 Posts

    I was considering on making a night scalper that trades only between 22:59 to 23:59 daily.  However, all brokers have a different GMT offset time on their servers.  Does anyone know how to have an input for this offset?  Thanks.

    #268890
    Customer
    43 Posts

    Just hard code the hours of trade for each broker. For GMT+2 brokers you want H21-23 period.

    #268892
    Customer
    119 Posts

    Sorry if I sound ignorant – but what does “hard code H21-23” mean?

    #268893
    Customer
    43 Posts

    Means to set the timing in the EA as set hours, rather than trying to have it automatically update for different brokers. H21-23 means 21:00 to 22:59. This comes from lots of testing of range scalping the last month. It is consistently the best hours across multiple pairs.

    #268894
    Customer
    119 Posts

    Got it.  Thanks.  However, how do I change the GMT offset in the input fields (after EA is in chart) to accommodate winter versus summer time change?

    #268895
    Customer
    43 Posts

    My broker (Darwinex) changes the broker time zone to account for Daylight Savings, so you don’t need to. You would need to check for any brokers you are using.

    https://blog.darwinex.com/end-dst-europe-october-27th-2019/

    #268889
    Customer
    1 Posts

    I’ve addressed a similar issue, that of not wanting to trade during “the swap” in the following way:

    1. Use the “Clone to Timezone” tool in the data manager to convert the Dukascopy charts (default UTC+0) over to whatever UTC your broker is in.  Mine was UTC+2.

    2. In the builder under “Trading Options”, use the “Limit Time Range” feature to the block of time you specifically want to trade.

    This has worked perfectly for me and I get no 40 pip spread trades opened up during the swap.  :-). It should work the same for you to get trades only during the last hour of the market.  Just make sure the time you block out matches your broker time…  at UTC+2, it would be exactly as you put it 22:59 to 23:59.  At Dukascopy default UTC+0, it would be 20:59-21:59.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.