Reply

MT4 ea code errors since todays upgrade to v134.846

22 replies

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

1 week ago #274171

I was generating files successfully and using as MT4 EA this morning but after upgrade the .mq4 files won’t compile properly. They have errors (see attached) Also is example sqx file and associated mq4 file with errors.

I have saved as mq5 file and it worked OK with MT5? Just seems to be with MT4 and I have tried many variations over many hours. I doubt it is my MT4 platform as it worked this morning and I don’t think there were any updates.

Any ideas? Need to get some work done asap..

Apart from this – keep up the great work. I love this program
cheers
Keith

Attachments:
You must be logged in to view attached files.

1

neilrickaby

Customer, bbp_participant, community, 27 replies.

Visit profile

1 week ago #274188

yes, I have the same issue. thanks

0

Dave_C

Customer, bbp_participant, community, 15 replies.

Visit profile

1 week ago #274190

I came axross this problem also and tried checking the  “use initial stop loss option” but the errors continued. Since I had not checked that option originally, I just clicked on the offending lines and commented them out and was able to recompile without errors.

 

I

1

neilrickaby

Customer, bbp_participant, community, 27 replies.

Visit profile

1 week ago #274191

thanks Dave_C, commenting out allows it to compile for me, but when I try to run it in StrategyTester I still get the “cannot load expert” message 🙁

0

Dave_C

Customer, bbp_participant, community, 15 replies.

Visit profile

1 week ago #274192

thanks Dave_C, commenting out allows it to compile for me, but when I try to run it in StrategyTester I still get the “cannot load expert” message 🙁

Can you post a log of your compilation errors and I’ll try to help.

My problems were all related to “use initial stop loss”. Sound as though there are more. Hoping to hear from Tomas here.

0

Dave_C

Customer, bbp_participant, community, 15 replies.

Visit profile

1 week ago #274193

The EA’s ran OK in Strategy Tester for me after commenting out the error lines.

 

 

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

1 week ago #274202

Glad to see that I wasn’t the only one.. Looking forward to hearing from Tomas as I’m sure its a bug to be fixed. I’ll try today with commenting the error lines out and see how that goes.

Thanks for your help guys..

0

Dave_C

Customer, bbp_participant, community, 15 replies.

Visit profile

1 week ago #274203

thanks Dave_C, commenting out allows it to compile for me, but when I try to run it in StrategyTester I still get the “cannot load expert” message 🙁

Thinking about your problem, could it be that the strategy depends on an indicator supplied by Strategy Quant but not loaded into your MT4 platform?

 

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

1 week ago #274204

Just letting you know that when I comment out the error lines it runs ok in the MT4 strategy tester for me..

I do have all the SQ indicators installed on my MT4 so ensure that you have that done befor any installations of SQ ea’s.

0

Kornel Mazur

Administrator, 5 replies.

Visit profile

1 week ago #274208

We had an issue with the updater which caused multiple problems with happen after upgrade from build 133 to build 134.

The safest solution is to wait until tomorrow build 135 which will fix all mentioned issues. Second option is to perform multiple updates of the files

You can find more info here: https://strategyquant.com/doc/strategyquant/problems-after-upgrading-from-build-133-to-134/

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

1 week ago #274223

Any news on when build 135 will be available? Thanks

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

1 week ago #274236

Just upgraded to v 135 but still got same errors when converting for MT4!!

Any ideas?

0

Richard Brennan

Customer, bbp_participant, community, 23 replies.

Visit profile

1 week ago #274239

Just upgraded to v 135 but still got same errors when converting for MT4!! Any ideas?

It’s very frustrating. My merged Portfolio EAs in MT4 are no longer accepted by the Platform with the following journal error.

I thought this would all be resolved in Build 135. Perhaps I need to revert back to Build 133.

 

Attachments:
You must be logged in to view attached files.

Rich B

0

Dave_C

Customer, bbp_participant, community, 15 replies.

Visit profile

1 week ago #274240

I resolved the problems by backing up the SQ directory, doing a FULL installation and copying back my own files from the backup.

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

1 week ago #274241

hmm.. I might try that but nervous.. Did you just copy the whole ‘user’ folder back? Any tips.

Will the licence still work?

Cheers

Keith

0

Viewing 15 posts - 1 through 15 (of 23 total)

1 2