Reply

MT4 ea code errors since todays upgrade to v134.846

25 replies

Anthony DE BARROS

Customer, bbp_participant, community, sq-ultimate, 14 replies.

Visit profile

4 weeks ago #274246

Hello, I have installed version 135 but the problem persists for MT4.

I also reinstall entirely, but my problem persists. A solution ?

I want to compile the strategy with SQ 4 business

Thx

0

Christopher Khng

Subscriber, bbp_participant, customer, community, sq-ultimate, 1 replies.

Visit profile

4 weeks ago #274194

I have the same problem also.  There seems to be a bug in V134.

V134 also caused some of my symbols to revert to EURUSD spontaneously when I press the Start green button when I try to run Custom Projects.  Wasted time troubleshooting and found this DOES NOT happen when I run the project instead by going to the first task, click the gear symbol and instead click Run Project from here.

Could you please fix these issues expeditiously?

 

Thanks,

 

Chris

 

0

Bogdan Z

Customer, bbp_participant, community, sq-ultimate, 1 replies.

Visit profile

4 weeks ago #274234

after doing a complete removal of program and complete fresh reinstallation of version 135, that compiling problem has disappeared and i could compile the strategy in mt4.

Thanks for the hard work guys , much appreciated

0

Dave_C

Customer, bbp_participant, community, 13 replies.

Visit profile

4 weeks ago #274237

Just upgraded to v 135 but still got same errors when converting for MT4!! Any ideas?

This also happened for me. I resolved it by renaming the current directory to SQBackup and performing a FULL Reinstallation (not the upgrade zip)

https://api.strategyquant.com/downloads?code=sqxzip135

and then copied back my own settings and files.

I suspect the problem may have been exacerbated by deleting the files and directories as detailed in the temporary fix.

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

4 weeks ago #274256

Thanks Dave_C

I just did exactly what you said and it now works perfectly again in converting to mq4 files that don’t get errors when compiling in MT4. THANK YOU!!!

I just copied the whole ‘user’ folder over and everything was exactly the same

 

0

kemelageni

Community, customer, bbp_participant, 11 replies.

Visit profile

3 weeks ago #274270

I take that back – took a break over the weekend and now it is back to producing mq4 errors same as before. Nothing has changed my end! I now have a brand new install of v135 with my old user files which did work for a bit but now SQ produces MT4 codes that are full of errors when it compiles in MT4. I have rebooted, double, triple checked all acctions but 99% sure it is an SQ fault. If I comment these error lines out the code works but it is messy and time consuming and reduces my trust in overall reliability.

Can someone from SQ please look into this issue urgently as it is very important I believe

Thank you

 

0

Dave_C

Customer, bbp_participant, community, 13 replies.

Visit profile

3 weeks ago #274312

In the absence of any reply from SQ, all I can report is that my full installation of v135 has been working normally.

It is possible in your case that you may have reimported your problem into your new version?

Have you tried reimporting just one existing .sqx file and using the included data. If that complies in MT4, then you would be able to ascertain that the problem exists in your imported user files.

Is is then probably a matter of incremental import until you re-encounter the error.

Since no others has posted since the issued was raised and commented, I am inclined to think the problem may be your end.

As I have said, I have not encountered any of your mentioned problems since i did the Full installation.

0

Dave_C

Customer, bbp_participant, community, 13 replies.

Visit profile

3 weeks ago #274313

You may care to upload just one .sqx file with mt4 generation problems problems and I will try a MT4 generation my end.

 

0

Bee trader

Subscriber, bbp_participant, customer, community, 28 replies.

Visit profile

2 weeks ago #274389

the SQX folks have confirmed that you need to upgrade to v135 preferably make it a clean installation. There was a bug in v134.

You can have many versions of SQX on your machine and it wont affect your license as it is machine/hardware specific. i.e. you can run v133, v135 on the same pc. If you want to switch machines log onto your dashboard and reset the license.

0

Anthony DE BARROS

Customer, bbp_participant, community, sq-ultimate, 14 replies.

Visit profile

2 weeks ago #274390

I do not know why, I had done what you said, all went well (I completely erased version 134) and today I have the same error coming back to generate MT4 .. . While I am in version 135

 

I’m not going to uninstall and reinstall everything every time?

0

Bee trader

Subscriber, bbp_participant, customer, community, 28 replies.

Visit profile

2 weeks ago #274392

you don’t need to erase anything yet, just install SQX into a different folder. or if you download the zip files, just unzip to your chosen location and run the StrategyQuantX.exe

I ended up installing clean install and not copying the user folder just in case there were some gremlins causing the issues to come back.

0

Viewing 11 posts - 16 through 26 (of 26 total)

1 2