Not logged in

Forums

Viewing 15 posts - 646 through 660 (of 802 total)
  • #201429 |
    Customer
    62 Posts

    Beta 7 is now ready to download and for testing: https://strategyquant.com/betaversion4 I hope everything will work as it should, there were quite many changes towards better performance. I’m looking forward to your comments.

    Mark, I can’t see the Beta7 download link. I am not looking in the right place?

    https://www.strategyquant.com/licenses/d?code=sqb7

    Thank you Karish.

    #201433
    Customer
    37 Posts

    Mark

    I am starting to work with beta 7 and it is giving an error message of no input databank set. I am not sure what to do with this. Is there a setting I missed? It won’t begin generating

     

    Josh

     

    #201434
    Karish
    Customer
    577 Posts

    Mark I am starting to work with beta 7 and it is giving an error message of no input databank set. I am not sure what to do with this. Is there a setting I missed? It won’t begin generating Josh

    i had the same error too, then tried the already created Templates of settings which are presented when you start the software,

    and everything worked, yeah i suppose that this error should be fixed somehow i dont know what casing it.

    #201438
    Customer
    286 Posts

    Hi Mark,

    spred of gui and responsivity and speed of generating strategies  ich much much better. Excellent. I would like to ask how what methodology did u use for testing accurancy between mt4 and sq4b7. Im dont have  similar results with using of birt tick data manager 🙁

    #201454
    Customer
    324 Posts

    SQ4 B7 builds up a massive temp folder under Appdata on C drive even if it is installed on D drive.  I run out of disk space after a couple of hours with a 60 gig temp folder full of .jar files. Is there a way to change the temp directory that SQ4 is using ?

    #201456
    Customer
    324 Posts

    Okey it was when storing chart data this happens. When this options is un ticked there is no buildup of temp. I figured it was the chartdata  since this has to be stored somewhere . It temps like 15 gig per min . It should only store the data of the strategies that make it to the data bank it seems it temps everything thought. It is not really a bug more like a feature that needs to be improved since it stores temp files of discarded strategies.

    #201457
    Customer
    324 Posts

    Hi Mark, spred of gui and responsivity and speed of generating strategies ich much much better. Excellent. I would like to ask how what methodology did u use for testing accurancy between mt4 and sq4b7. Im dont have similar results with using of birt tick data manager 🙁

    Did you  retest on tick data in SQ4. ?

    • This reply was modified 5 months ago by  mabi.
    #201463
    Participant
    27 Posts

    When I want start the Engine SQ4 beta7 I get this error message: NO INPUT DATABANK SET

    Any idea how can I solve this issue?

    Regards Chris

    #201464
    Administrator
    3055 Posts

    Hello,

    No input databank set error – there is one missing setting in default Builder configuration. Please go to Home page and choose on eof the build configurations there, then you can modify it. It should fix the problem.

    Too many temp files – we’ll have to handle it better. For now I think you shoudl store chart data only for retested strategies, and don’t store them in Buiulder, where a big number of strategies is generated and then thrown away anyway.

    Discrepancies in tests between SQ and MT4 – yes, we used tick data. There could be some issues, but majority of strategies should work. We tested single data strategies though, not multi TF or multi symbol strategies.

    One thing you should do is reserve at least 1000 bars before start of the test. This amounts to approximately 3-4 months of data for H1 timeframe. So start your testing in SQ and MT4 with start at 4 months after your imported data start. This will make it same for MT4 and SQ. Also, make sure you use the same spread, slippage, etc. in MT4 as in SQ4.

    If you have problems with backtest match please open a task and attach a few of these strategies that don’t match there (.sq4 files, not .mq4). We’ll look at it and fix it.

     

    Mark
    StrategyQuant architect

    #201469
    Participant
    27 Posts

    Hi, the rankings seemed to be ignored? Two strategies are build which mustbe fully out of the ranking range but they are in the result of the data base. When I change the selection in the strategy acceptance condition “Throw away strategies that fit conditions” then it works……

    Regards Chris

    Ranking

    Attachments:
    You must be logged in to view attached files.
    #201473
    Participant
    27 Posts

    Hi, why is the graphic PL in money by Year positiv green but the year 2017 above is minus $-26.0???

    Regards Chris

    Attachments:
    You must be logged in to view attached files.
    #201475
    Participant
    27 Posts

    Hi how far is the developing in the robustness test area? All my good strategies in SQ4 have problems in the first selected robustness test which can not be true?

    Attachments:
    You must be logged in to view attached files.
    #201478
    Customer
    905 Posts

    Hi Team,

    I’m rather confused with my first interaction with SQ4 Beta 7.

    Imported existing DukasCopy tick data. Loaded an existing SQ3 strategy that used the very same data in SQ3.

    Strategy loads and displays existing SQ3 backtest values and equity curve.

    Run retest, and get this warning:

    SQ identified some problems when testing the strategy – strategy is most probably not suitable for trading on real account !
    These problems affect either strategy logic or accuracy of backtesting.
    Strategy produces too many ambiguous trades – trades that begin and end at the same bar

    How do I set the retest to use trade at bar open like SQ3?

    Thanks,

    Mike

    #201486
    Customer
    324 Posts

    Hi how far is the developing in the robustness test area? All my good strategies in SQ4 have problems in the first selected robustness test which can not be true?

    It seems it is not working very good this was the first i tested. Some seems to work thought. Randomise parameters definetely do not work. I had all failed of 100 that looked the same as yours. They were made on EURUSD and i retested them on GBPUSD and most of them worked just fine on that instrument. If the strategies that comes out from SQ4 are robust this program is awesome indeed. Most of SQ3 strategies has very little trades maybe only 10 % of the ones that i am trading actually trade enought to be worth trading running live for more then 1 year *300.  The strategies i found on SQ4 B7 trades atleast 10 times more on average even the multi time frame strategies seems avesome if you set the genetic evo settings correct. It do not work with the default settings. So i do not think SQ team have tested this very much if they had they would had found a shit load of  bugs. SQ4 still stops after 3-4000 generated strategies. That was a complain before i had it is said to be fixed but it is now even worse. If the data range used is to large the trades do not show up in the trade list was the same on Beta 6 but diffrent on diffrent computors. There is still alot of bugs but hopefully we can have something great in the end. Multi time frame startegies looking at a lower time frame chart quickly found 100 strategies that were beutiful with high winrate . If SQ4 works like this i will ditch SQ3 immediately indeed. If it  doesent work it is probably the fasted curvefitter in the Solar system which is not possible since it takes alot more power to curvfit to a data stream then it takes SQ4 to find strategies.

     

    #201509
    Customer
    1 Posts

    Hi, i am really sure i am doing something wrong because every strategy I create with sq4 beta 7, testes with 1 min tick simulation for 1hour timeframe is totally different when I test it with mt4 same data. So I know there is something i’m doing wrong but i don’t know what is it, could you please help me with this? I have copied the indicators into the indicators mt4 folder so every strategy is compiling without errors.

    -When i create multitimeframe strategy they never have problems compiling but they do not execute any trade during backtest

    -All my strategies use the same exit which is exit after bars and all the entries are at market

    If you needed more I can upload photos, strategyes or my mt4 folder, but as it happened with every strategy I tested I am sure it has to be something I did wrong. Thanks you in advance

Viewing 15 posts - 646 through 660 (of 802 total)

You must be logged in to reply to this topic.